Color Management in PS CS4

From ColorWiki

Jump to: navigation, search
Reserved Article

This page is a
Reserved Article.
For more details see
Reserved ColorWiki Articles

ColorNews

This reserved article originally appeared in CHROMiX ColorNews Issue 34 on November 26, 2008.

Click here to see the original in its original context.
Email
colornews(at)chromix.com to subscribe to the ColorNews newsletter.

Contents

Color Management in Photoshop CS4

With the recent release of Adobe Photoshop CS4, plenty have written about the new features in this newest version of the gold standard in image manipulation. This month's article will present an overview of what's new in Photoshop's color management.

Incidentally, CHROMiX ColorNews newsletters are always sent out in text-only format as a courtesy to our readers (to not fill up their inboxes with large emails) As a result, this current article might seem rather dry without pictures of what we're referring to. So we encourage all who can to browse over to the www.colorwiki.com site and see the Reserved Article version of this issue. http://www.colorwiki.com/wiki/Color_Management_in_PS_CS4 There, we have posted screen shots of all the dialog boxes we mention here.

COLOR SETTINGS

Color settings box on a Mac

(Edit > Color Settings)

Sample of the list of included profiles

At first glance, the Color Settings dialog box is relatively unchanged from the previous versions. Under the hood, however, you'll find that several new profiles are included. If you click the drop down box for Working Spaces: CMYK, you will find the latest GRACoL and SWOP profiles from 2006.

Those who have need to convert to a larger CMYK working space than the often-used "US Web Coated SWOP2" profile will find that the Coated GRACoL 2006 profile is a great improvement in gamut, and is a good representation of a press running to a G7 standard.

Also note an additional checkbox under Conversion Options: "Compensate for Scene-referred Profiles." It is recommended that this checkbox stay checked, unless you are trying to duplicate colors in other programs that do not compensate for scene-referred profiles. Color profiles are said to be scene-referred if their tone-response curves are based on the conditions in the typical scene. Color profiles are said to be output-referred if their tone-response curves are based on the conditions in the typical viewing environment. This choice may be more important to those working with moving pictures and video. Check the Photoshop help menus for more information on scene-referred profiles.

PRINTING

Printer dialog box on a Mac

(File > Print)

The left side of this dialog box features some new soft-proofing options. There are now check boxes allowing you to see a gamut warning and/or simulate your paper white right here in the preview window. Previously, you would have had to go to the View > Proof setup > Custom section to view your image with these features.

The top center of this page now has a small printer icon next to the Printer selection box. This button will automatically bring up the printer maintenance utility program for the printer selected. This is a great way to check your inkjet nozzles just before printing a big job.

The right side of the page is essentially the same on CS4 as it was with CS3. You still choose whether you want Photoshop, or the printer, to manage colors (or whether you want No Color Management), and you choose your rendering intent, black point compensation, etc.

SOFT PROOFING

(View > Proof Setup > Custom)

This section is unchanged from previous versions of CS, except for the multi-color profile issue I'll be mentioning below.

CONVERT TO PROFILE

Convert to... dialog box on a Mac

(Edit > Convert to Profile...)

While the "Assign Profile" dialog box has not changed, the Convert to Profile dialog has much more functionality. Click the new "Advanced" button, and you are now presented with a choice of almost any profile type you can think of. Just like before, you can still convert to an RGB, CMYK or Gray profile, but now you have the added ability to:

Each of these choices comes with a drop down box so you can choose which profile you want to use in each category.

MULTICHANNEL PROFILES

Just a note here: We are not talking about profiles for a typical modern inkjet printer that has more than the usual four inks. Multi channel profiles (or "n-color" profiles) are very specialized animals that handle 5, 6, 7 or more inks, and only work on certain multichannel printers/presses and the rare RIPs that can process multi channel printing.

The ability to convert to a multichannel profile is a big step for Photoshop, and those who work with a Roland 6-channel printer using spot colors (or some such monster) will be pretty excited to add this useful tool to your arsenal. Epson is rumored to be coming out with new printers that will be using multichannel inks, so this feature may have wider applications in the future.

While the conversion to multichannel profiles works very well - the preview or visual display of that profile conversion does not. According to Adobe, the calculation required to do an accurate soft proof of these profiles would take so long as to be unusable at this point in time. However, they did want to make available this conversion to multichannel separations, and didn't want to remove the feature just because the soft proofing was not there yet.

[We should note that CHROMiX has patent-pending technology called ColorCast which creates specialized soft proofing profiles that will accurately soft proof multi-channel profile conversions quickly and accurately. ColorCast is available as an optional add-on for ColorThink Pro 3. visit http://www2.chromix.com/colorthink/pro/pro_colorcast for more information]

You can see the preview inconsistency when you look at how a converted image is displayed. For example, compare the preview of your image when using the Convert to Profile "Preview" checkbox with the image after conversion to the multichannel profile, and you can probably see a noticeable difference where you would not expect one. We looked at a preview of the unsharp mask filter and saw the preview as almost monotone. Similar results were found with the soft proofing function in View > Proof Setup, and the Print dialog preview.


For those worried about having to learn a new interface, the Adobe folks have left alone that which works well. But they have snuck in more functionality in reasonable places where you need it and want it. While they don't yet have accurate previews using multi color profiles, the ability to convert to multi color profiles in Photoshop has been on the wish list for many years with many printers, and its inclusion might come to be very timely in the near future.


Thanks for reading,

Patrick Herold

Chromix Tech Support

Color Management in Photoshop CS4 supplemental

ColorNews

This reserved article originally appeared in CHROMiX ColorNews Issue 35 on January 21. 2009.

Click here to see the original in its original context.
Email
colornews(at)chromix.com to subscribe to the ColorNews newsletter.

Last month's ColorNews included an article on Adobe's new Photoshop CS4. In our eagerness to get it out the door, we neglected to mention a few interesting and important notes.

Device Link Profile Limitations

While Photoshop CS4 supports the application of device link profiles, it is important to note that you can only use profiles that convert to and from the same color model. So, if you have an RGB file, you can only use an RGB->RGB device link. For CMYK files, only CMYK->CMYK device links will work. For many linkers, this will suffice, but for those experimenting with customized gamut mapping and other effects for their RGB->CMYK conversions, you'll need to continue using either device link plug-ins or tools outside Photoshop.

Some users have complained that CS4 drops the image into the same color space as it started. In other words, if your file was originally in Adobe RGB(1998) then it is deposited into Adobe RGB(1998) after conversion. To the complainers we say, "What did you expect?" or perhaps more importantly "How would it know to do anything else?"

It's true that post-link, a file may be intended to be in a different color space. If you were testing a device link that converted from GRACoL 2006 to your inkjet's paper profile then the converted file should indeed be assigned your inkjet profile in order to appear correct in Photoshop. But, if you were testing a device link that converted from GRACoL 2006 to GRACoL 2006 with heavy black generation, then the assigned profile should be unchanged. But the most important point here is that the ICC spec doesn't require that the entire source and destination profiles be embedded inside device link profiles. So Photoshop has no reliable way of knowing (or doing) what should be done. It is the nature of device link profiles today. Some profiling tools like Link-o-later DO embed the profiles for reference and future use and it's a great idea - but not something Photoshop can rely on.

Abstract Profile Application

CS4 can finally use abstract profiles. In it's current incarnation, Photoshop uses your current document profile as the source and destination with the abstract profile in between.

To clarify - when you choose an Abstract profile from "Convert to Profile...," Photoshop will convert via: (current profile) -> abstract profile -> (current profile). At this time you are not able to select the abstract profile as part of an RGB->CMYK conversion.

Interestingly, Photoshop allows you to select a rendering intent during this conversion. Abstract profiles do not contain tables for different rendering intents, so the intents at work are from the document's current profile. I cannot see why any intent other than Relative Colorimetric would be used in this conversion, but I'll keep my ear to the ground for strategies and ideas.

Some are unhappy that this conversion method creates an extra step and could degrade the image. I suppose this is a possible issue, but I'm just glad to see the ability to use abstract profiles is finally available. Time will tell if this powerful profile type will finally get the exposure it deserves.


-Steve Upton

January, 2009


Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox